Service incident related to widgets not refreshing is now resolved. Please contact us at support@geckoboard.com if you experience any further issues.
Posted May 14, 2026 - 12:57 UTC
Monitoring
We've released an update to resolve the issues with widgets not refreshing. We'll continue monitoring the situation and update you shortly
Posted May 14, 2026 - 12:52 UTC
Identified
We have identified the root cause for the issue that is currently preventing widgets from refreshing and are currently working on its fix. More info to follow.
Posted May 14, 2026 - 12:39 UTC
Investigating
We are currently investigating potential issues with widgets not refreshing. We'll provide updates as we learn more.