The maintenance has been completed successfully. Thank you for your patience.
Please don't hesitate to reach out to our Customer Success team if you encounter any issues, and have a great weekend!
Posted May 16, 2026 - 14:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2026 - 08:30 UTC
Scheduled
We will be performing essential maintenance on a database which powers a subset of Geckoboard integrations. New Zendesk Integration Connections will defer importing data until the maintenance is complete. Existing connections and associated dashboard instruments will continue to work as normal.
We aim to complete the work as quickly as possible to minimise interruption and will post updates as we progress.
Thank you for your patience.
Posted May 12, 2026 - 15:50 UTC
This scheduled maintenance affected: Web Application.