Issues with Dropbox widgets not loading

Incident Report for Geckoboard

Resolved

The issue affecting Dropbox accounts has been resolved, and widgets are loading normally. If you continue to have any issues, please reach out to our team at support@geckoboard.com, and we'll help further.
Posted Aug 21, 2026 - 17:18 UTC

Monitoring

Dropbox implemented a fix at 14:26 UTC, and widgets are gradually coming back online. We’re continuing to monitor the situation.
Posted Aug 21, 2026 - 14:32 UTC

Identified

Some customers are experiencing issues with their Dropbox widgets not loading due to an ongoing Dropbox incident: https://status.dropbox.com/incidents/q9v98cvgfbms. We’re monitoring the situation and will share another update as soon as we have more information.
Posted Aug 21, 2026 - 14:09 UTC