Widgets Fail to Load on TV Screens

Incident Report for Geckoboard

Resolved

The incident involving some widgets failing to load on TV screens has now been resolved. Thank you for your patience.
Please contact us at support@geckoboard.com if you need any further assistance.
Posted Mar 10, 2026 - 16:46 UTC

Monitoring

A fix has been implemented for widgets failing to load on TV screens, and we are monitoring the results. We will provide further updates as they are available.
Posted Mar 10, 2026 - 16:23 UTC

Investigating

We are currently investigating an issue causing some dashboard widgets to fail to load over TV connections. We have identified the cause and are currently working to resolve it. We'll provide another update soon.
Posted Mar 10, 2026 - 16:13 UTC
This incident affected: Web Application.