Investigating issues with Airtable

Incident Report for Geckoboard

Resolved

The issue with Airtable connections has been resolved. We’ve been monitoring closely, and all systems remain stable. If you experience any further issues, please don’t hesitate to reach out.
Posted Feb 12, 2026 - 12:05 UTC

Monitoring

We’ve released an update to resolve the issue with Airtable connections, and your dashboards should now be working smoothly. We’ll continue monitoring, but feel free to reach out if you notice any further issues.
Posted Feb 12, 2026 - 11:41 UTC

Identified

Some customers may be experiencing issues with their Airtable connections. We’ve identified that the issue appears to be related to Airtable’s API and have contacted their team for support. We’re monitoring the situation and will share updates as we learn more.
Posted Feb 12, 2026 - 10:22 UTC

Investigating

We are currently investigating issues with the Airtable integration. We'll provide updates as we learn more.
Posted Feb 12, 2026 - 09:44 UTC