Investigating issues with new Aircall connections

Incident Report for Geckoboard

Resolved

The issue affecting the creation of new Aircall integrations has been fully resolved. All services are operating normally. Please contact us at support@geckoboard.com if you experience any further issues.
Posted Mar 02, 2026 - 11:33 UTC

Monitoring

The fix is out! All connections, including newly created ones, are functioning as expected. Please get in touch if you still notice any issues.
Posted Mar 02, 2026 - 10:57 UTC

Investigating

We’re currently investigating an issue affecting users attempting to create new Aircall integrations.

Existing Aircall connections remain unaffected at this time.
Posted Mar 02, 2026 - 10:42 UTC