Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2026 - 09:35 UTC
Scheduled
We will be applying essential OS security updates to a number of the databases which power the Geckoboard app.
During this time, the Geckoboard app will be temporarily unavailable. We expect the update to take no longer than 2 minutes and will be monitoring closely.
We apologise for the inconvenience and will keep you posted with progress. Thank you for your patience.
Posted Jul 09, 2026 - 09:34 UTC
This scheduled maintenance affected: Web Application and Push API.