Some legacy dashboards unavailable

Incident Report for Geckoboard

Resolved

The issue affecting legacy dashboards has now been resolved.

Thank you for your patience while we worked on a fix. If you continue to experience any issues, please contact us at support@geckoboard.com.
Posted Jun 29, 2026 - 13:22 UTC

Monitoring

We've released an update to resolve the issue. All dashboards should be loading seamlessly again. We'll continue monitoring the situation and update you shortly.
Posted Jun 29, 2026 - 13:02 UTC

Identified

We’re investigating an issue affecting some customers using our legacy dashboards, in which they may fail to load.

We’ve identified the root cause and are actively working on a fix. We’ll provide another update as soon as we have more information.
Posted Jun 29, 2026 - 12:34 UTC