Issues logging into Geckoboard

Incident Report for Geckoboard

Resolved

The incident related to login issues is now resolved. Thank you for your patience.
Please contact us at support@geckoboard.com if you need any further assistance.
Posted Feb 12, 2026 - 17:32 UTC

Monitoring

We’ve released an update that resolves the login issues with Geckoboard. We’ll continue monitoring, but please reach out to support@geckoboard.com if you need any help.
Posted Feb 12, 2026 - 17:19 UTC

Identified

We are currently investigating an issue preventing users from logging into Geckoboard. We have identified the cause and are currently working to resolve it. We'll provide another update soon.
Posted Feb 12, 2026 - 17:06 UTC