Investigating issues with Airtable connections

Incident Report for Geckoboard

Resolved

The issue with Airtable connections has been resolved. If you run into any further issues, please don't hesitate to get in touch.
Posted Feb 13, 2026 - 10:03 UTC

Monitoring

We've released an update to resolve the issues with the Airtable connections. We'll continue monitoring the situation and update you shortly.
Posted Feb 13, 2026 - 08:57 UTC

Investigating

We're noticing issues with Airtable connections again and are working on it. We'll provide updates as we learn more.
Posted Feb 13, 2026 - 07:52 UTC