The upgrade has been completed successfully. Thank you for your patience.
If you see any issues, please reach out to us.
Posted Apr 25, 2026 - 09:26 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 25, 2026 - 09:06 UTC
Scheduled
We’re performing maintenance on databases which power a number of Geckoboard integrations. During this time, some integrations, including Datasets, Aircall, TikTok & Monday will be temporarily unavailable.
The interruption is expected to last no longer than 30 minutes. We apologize for any inconvenience and appreciate your understanding.
Posted Apr 24, 2026 - 09:56 UTC
This scheduled maintenance affected: Web Application and Push API.